夜莺项目发布 v6.1.0 版本,增强可观测性数据串联

大家好,夜莺项目发布 v6.1.0 版本,这是一个中版本迭代,不止是 bugfix 了,而是引入了既有功能的增强。具体增强了什么功能,下面一一介绍。

1. 增强可观测性数据串联

从 v6.1.0 开始,对日志索引模式做了增强,支持设置某个字段的展示格式为 URL,配置方式如下:

{{value}}就是这个字段原始的值,可以把这个字段拼接到 URL 中,把这个字段展示成链接,这样用户在查看日志数据的时候,通过这个链接,就可以跳转到某个其他页面。典型的场景是日志和链路追踪数据的串联,比如日志里面有 traceId 字段,可以把 traceId 字段设置成 URL,点击这个 traceId 就可以跳转到链路追踪系统,查看这个 traceId 的链路追踪数据。

当然,具体某一行日志,除了支持 JSON 展示方式,还支持了 Table 展示方式,提升易用性。

其次,还增强了监控大盘的蜂窝图、表格的下钻能力。表格支持了单行下钻链接的配置,比如 mysql 的监控,可以做一个 mysql 实例的表格作为入口,然后点击每个实例的下钻链接可以跳转到实例详情的大盘,这样就实现了大盘之间的跳转和数据串联,举例:

配置下钻链接的时候,可以支持配置多个,可以支持引用不同的变量:

构建可观测性体系,数据串联是非常重要的一环,夜莺会持续增强这方面的能力。

2. 内置自动更新 v6 所有小版本的表结构

夜莺的版本升级,很多老铁不知道怎么做。从 v6.1.0 开始,继续简化了升级步骤。如果你是 v6 的其他小版本(包括 ga 版本),升级到 v6.1.0 的话,无需再手工更新数据库表结构,夜莺会自动帮你更新(当然,前提是夜莺所用的数据库账号得具备数据库 alter 权限),你只需要替换二进制和 integrations 目录,然后重启进程即可。如果使用的容器部署方式,只需要更新镜像版本然后重新发布容器即可。

不过,如果你的版本是 v6.0.0-ga.9 之前的老版本,还需要调整配置文件 config.toml(如果使用了 n9e-edge 模块,还要检查 edge.toml),确保配置文件中[HTTP]配置段下打开了 API 相关配置:

那如果你是 v5 的版本,需要先升级到 v5.15.0,然后再通过 n9e-cli 工具进行升级,升级步骤见:https://flashcat.cloud/docs/content/flashcat-monitor/nightingale-v6/upgrade/。v5 版本已经封版不再提供社区支持,如果你是开源用户,建议升级到 v6 版本,如果你是企业用户那无所谓,合同履约期内,会一直提供支持。v6 是一个 LTS 版本,支持时间是 2 年,从 2023.7.29 到 2025.7.29。

3. 其他更新

其他更新如下,具体可以访问官网下载中心https://flashcat.cloud/download/nightingale/了解:

夜莺功能特点

夜莺会长期发展下去吗?

夜莺开源项目现在托管在中国计算机学会开源发展委员会,中立的组织,不会修改开源协议,大家尽可放心。

夜莺项目的核心成员,创业成立了快猫星云公司,提供企业级的监控、可观测性能力,开源和商业是互利共生的关系,除非创业失败,否则一定会长期支持开源发展。

最后

如果您觉得夜莺项目不错,欢迎到 github:https://github.com/ccfos/nightingale给我们一颗小 :-)