Kotlin 1.9.20 发布

Kotlin 1.9.20 版本已发布,适用于所有目标的 K2 编译器已进入 Beta阶段,Kotlin Multiplatform 已进入稳定阶段。

此版本的一些亮点更新如下:

JetBrains 的 Kotlin 团队正在继续稳定新的 K2 编译器,这将带来重大的性能改进,加快新语言功能的开发,统一 Kotlin 支持的所有平台,并为多平台项目提供更好的架构。

随着 1.9.20 版本的发布,新的 K2 编译器已面向所有平台进入 Beta阶段: JVM、Native、JS 和 Wasm。这意味着你现在可以在任何 Kotlin 项目中试用 K2。

Kotlin 团队通过成功编译数十个用户和内部项目,确保了新编译器的质量。大量用户也参与了稳定过程,在他们的项目中尝试新的 K2 编译器并报告他们发现的任何问题。大量用户也参与了稳定化过程,在他们的项目中试用新的 K2 编译器,并报告了他们发现的任何问题。

Kotlin 1.9.20 版本还在 kapt 编译器插件中引入了 K2 支持。现在,所有重要的 Kotlin 编译器插件都支持 K2。其中包括 kapt、serialization、AtomicFU、Lombok、SAM with receiver、all-open、no-arg、jvm-abi-gen、Android Lint 和 Jetpack Compose 编译器插件。支持 K2 的 Kotlin Symbol Processing (KSP) 将于 Kotlin 1.9.20 后一周内发布。

如果你使用的是任何其他编译器插件,建议检查其文档以查看它们是否与 K2 兼容。

Kotlin 的下一个主要版本是 2.0.0,新的 K2 编译器将作为默认和稳定版本全面提供。为了尽快解决发现的任何问题,项目团队计划频繁发布一系列小型 Kotlin 2.0 稳定版,包括 Beta1、Beta2、Beta3、RC1 和 RC2。

在发布 Kotlin 2.0.0-RC1 时,其计划确保与其他版本的 Kotlin 编译器编译的代码的二进制兼容性,并消除用 K2 编译的二进制文件中毒现象。使用户能够在生产环境中使用新的 K2 编译器。

K2 编译器即将完成其稳定化过程并在 Kotlin 2.0 中默认启用,因此项目团队也呼吁尽可能多的开发人员来试用 K2 并报告任何存在的潜在问题。

更多详情可查看官方博客。