Ubuntu Pro 包更新无法禁用引用户不满

一名 Ubuntu 用户在 Launchpad 上提交了一份针对 update-manager 的错误报告,表达了自己对 Ubuntu LTS 版本的软件更新工具 (Software Updater tool) 无法禁止显示 Ubuntu Pro 软件包更新的不满。

每次调用软件更新程序时,我都会看到一个 Ubuntu Pro 安全更新列表,底部还有一条信息,告诉我需要启用 Ubuntu Pro 才能更新,只有一个按钮可供选择,那就是"Remind Me Later"。我搜索了一下 Ubuntu Pro,想知道它到底是什么,最后得出的结论是我不需要它;但似乎没有任何方法可以永久拒绝安装它。每次重启电脑,我都会再次看到同样的文件,唯一的选择又是启用 Pro 或稍后提醒,而这两个选项都不能反映我的意愿和愿望。这究竟是一个选项,还是必须升级?作为用户,我对此感到很困惑。

他表示,也许这只是一个非常拙劣且引导性的营销伎俩,而不是软件本身存在 bug;但无论如何,有关 Ubuntu Pro 的这一困扰表明软件更新程序存在缺陷,官方应该提供一种能让用户拒绝升级的方法。

Canonical 于去年更新了 update-manager(又称 Software Updater tool),无论用户系统是否启用 Ubuntu Pro,它都会显示可用的 Ubuntu Pro 软件包更新列表(如果未启用,则无法安装)。

还有人反映称,对于一些不太懂行的人而言,此举更加迷惑。“我接到一些客户的电话,他们不知道自己的系统出了什么问题,在进行更新时会看到一个更新管理器窗口,里面有一些灰色的软件包,你无法删除,除非你启用 ubuntu pro。”

Canonical 的 Oliver Grawert 对此进行了回复:

Pro 是一项完全免费的服务,适合个人和小型企业使用,它为用户提供了 2.5 多个附加软件包的安全修复……为了维护这一点,canonical 安全团队必须扩展规范的安全团队。维护这 2.5 万个软件包是有成本的,canonical 在这里所做的就是让企业为这些额外的工作付费,然后再免费提供给社区…

为了确保这些企业不会免费攫取,需要建立一个控制机制,这也是为什么需要注册才能获得。

并反问用户,是更愿意安全漏洞被知而不报从而被恶意行为者利用,还是更愿意在更新时获得可用修复程序的列表。此外,他还邀请有想法的用户提出解决问题的方案,项目团队将进行考量:https://discourse.ubuntu.com/t/ubuntu-pro-faq/34042